Click or drag to resize

BrepFace Properties

The BrepFace type exposes the following members.

Properties
  NameDescription
Public propertyBrep
Gets the Brep that owns this face.
Public propertyFaceIndex
Index of face in Brep.Faces array.
Public propertyId
Gets or sets the persistent id of this Brep face. By default, the id is Guid.Zero. Note, Rhino does not set this id. Thus, the property is available for use as a way of tracking Brep faces.
Public propertyIsSurface
Gets a value indicating whether the face is synonymous with the underlying surface. If a Face has no trimming curves then it is considered a Surface.
Public propertyLoops
Loops in this face.
Public propertyMaterialChannelIndex
This face's rendering material channel index.
Public propertyCode exampleOrientationIsReversed
true if face orientation is opposite of natural surface orientation.
Public propertyOuterLoop
Every face has a single outer loop.
Public propertyPackId
0 if the pack it is unset, or >0 if the set pack id.
Public propertyPerFaceColor
If per-face color is "Empty", then this face does not have a custom color
Public propertyProxyBrepSubDFaceId
If this face is part of a brep created by SubD.ProxyBrep(), then the subd component id of the corresponding SubD face is returned. Otherwise 0 is returned.
Public propertySurfaceIndex
Surface index of the 3d surface geometry used by this face or -1
Top
See Also