Click or drag to resize

Arc Properties

The Arc type exposes the following members.

Properties
  NameDescription
Public propertyAngle
Gets or sets the sweep -or subtended- angle (in Radians) for this arc segment.
Public propertyAngleDegrees
Gets or sets the sweep -or subtended- angle (in Degrees) for this arc segment.
Public propertyAngleDomain
Gets or sets the angle domain (in Radians) of this arc.
Public propertyCenter
Gets or sets the center point for this arc.
Public propertyCircumference
Gets the circumference of the circle that is coincident with this arc.
Public propertyDiameter
Gets or sets the Diameter of this arc.
Public propertyEndAngle
Gets or sets the end angle (in Radians) for this arc segment.
Public propertyEndAngleDegrees
Gets or sets the end angle (in Degrees) for this arc segment.
Public propertyEndPoint
Gets the end point of the arc.
Public propertyIsCircle
Gets a value indicating whether or not this arc is a complete circle.
Public propertyIsValid
Gets a value indicating whether or not this arc is valid. Detail: Radius>0 and 0<AngleRadians()<=2*Math.Pi.
Public propertyLength
Gets the length of the arc. (Length = Radius * (subtended angle in radians)).
Public propertyMidPoint
Gets the mid-point of the arc.
Public propertyPlane
Gets or sets the plane in which this arc lies.
Public propertyRadius
Gets or sets the radius of this arc.
Public propertyStartAngle
Gets or sets the start angle (in Radians) for this arc segment.
Public propertyStartAngleDegrees
Gets or sets the start angle (in Degrees) for this arc segment.
Public propertyStartPoint
Gets the start point of the arc.
Public propertyStatic memberUnset
Gets an Arc with Unset components.
Top
See Also