Click or drag to resize

AnnotationBase Properties

The AnnotationBase type exposes the following members.

Properties
  NameDescription
Public propertyAlternateDimensionLengthDisplay
Alternate length display units and format
Public propertyAnnotationType
Type of annotation
Public propertyDecimalSeparator
Set or get the decimal separator c
Public propertyDimensionLengthDisplay
Length display units and format
Public propertyDimensionScale
Gets or sets the dimension scale
Public propertyDimensionStyle
If there are no overrides then the parent style is returned otherwise the dimension style saved with the annotation is returned.
Public propertyDimensionStyleId
Id of this annotation's parent dimstyle If this annotation has overrides to dimstyle properties, those overrides will be represented in the DimensionStyle returned by DimensionStyle(ParentStyle)
Public propertyDrawForward
Gets or sets whether the text is oriented towards the reader when viewed from behind
Public propertyDrawTextFrame Obsolete.
Gets or sets whether to draw a frame around a text mask
Public propertyFirstCharFont
Returns the font used by the first run of text in an annotation
Public propertyFont
The base Font for the text of the annotation. The text string is rich text and therefore a different font that the base font can be associated with sub strings of the text
Public propertyFormatWidth
Text format width (Wrapping rectangle)
Public propertyHasPropertyOverrides
Public propertyMaskColor
Color to use for drawing a text mask when it is enabled. If the mask is enabled and MaskColor is System.Drawing.Color.Transparent, then the viewport's color will be used for the MaskColor
Public propertyMaskColorSource
Gets or sets whether the mask background color is from the background or from a color
Public propertyMaskEnabled
Determines whether or not to draw a Text Mask
Public propertyMaskFrame
Gets or sets whether to draw a frame around a text mask
Public propertyMaskOffset
Offset for the border around text of the rectangle used to draw the mask. This value multiplied by TextHeight is the offset on each side of the tight rectangle around the text characters to the mask rectangle. The default value is 0.1.
Public propertyMaskUsesViewportColor
If true, the viewport's color is used for the mask color. If false, the color defined by MaskColor is used
Public propertyParentDimensionStyle
The parent dimension style associated with this annotation
Public propertyPlainText
Text stripped of RTF formatting information
Public propertyPlainTextWithFields
Text stripped of RTF formatting information and with field expressions intact
Public propertyPlane
Plane that this annotation lies on
Public propertyRichText
Text including additional RTF formatting information
Public propertyText Obsolete.
Text including additional RTF formatting information
Public propertyTextFormula Obsolete.
See RichText
Public propertyTextHasRtfFormatting
Public propertyTextHeight
AnnotationBase.TextHeight Gets the parent dimstyle for the annotation and gets or sets the text height in the dimstyle
Public propertyTextIsWrapped
Is text wrapping on
Public propertyTextModelWidth
Width of text in the model
Public propertyTextRotationDegrees
Rotation of text in degrees
Public propertyTextRotationRadians
Rotation of text in radians
Top
See Also