Click or drag to resize

RhinoPageView Properties

The RhinoPageView type exposes the following members.

Properties
  NameDescription
Public propertyActiveDetail
Returns the active detail object. If no detail is active, or if the page is active, then null is returned.
Public propertyActiveDetailId
Returns the id of the active detail. If no detail is active, or if the page is active, then Guid.Empty is returned.
Public propertyActiveViewport
Gets the active viewport. The ActiveViewport is the same as the MainViewport for standard RhinoViews. In a RhinoPageView, the active viewport may be the RhinoViewport of a child detail object. Most of the time, you will use ActiveViewport unless you explicitly need to work with the main viewport.
(Overrides RhinoViewActiveViewport.)
Public propertyCode examplePageHeight
Height of the page in the document's PageUnitSystem
Public propertyCode examplePageIsActive
Returns true if the page is active, rather than any detail view. This occurs when the MainViewport.Id == ActiveViewportID.
Public propertyCode examplePageName
Same as the MainViewport.Name.
Public propertyPageNumber
Gets or sets the runtime page number and updates the page number for all of the other pages. The first page has a value of 0.
Public propertyCode examplePageWidth
Width of the page in the document's PageUnitSystem
Public propertyPaperName
Returns the name of the layout's media, or paper (e.g. Letter, Legal, A1, etc.), used to determine the page width and page height.
Public propertyPrinterName
Returns the name of the layout's destination printer.
Top
See Also