Click or drag to resize

RhinoAccountsManager Methods

The RhinoAccountsManager type exposes the following members.

Methods
  NameDescription
Public methodStatic memberExecuteProtectedCode
Any synchronous method in the IRhinoAccountsManager class must be executed within the function passed to this method, or an InvalidOperationException will be thrown.
Public methodStatic memberExecuteProtectedCodeAsync
Any asynchronous method in the IRhinoAccountsManager class must be executed within the function passed to this method, or an InvalidOperationException will be thrown.
Public methodStatic memberGetAuthTokensAsync(String, String, SecretKey, CancellationToken)
Asynchronously retrieves auth tokens with the given criteria from the Rhino Accounts server.
Public methodStatic memberGetAuthTokensAsync(String, String, IEnumerableString, String, NullableInt32, Boolean, IProgressRhinoAccoountsProgressInfo, SecretKey, CancellationToken)
Asynchronously retrieves auth tokens with the given criteria from the Rhino Accounts server.
Public methodStatic memberRevokeAuthTokenAsync
Invalidates/revokes an IOAuth2Token object from the Rhino Accounts server.
Public methodStatic memberTryGetAuthTokens(String, SecretKey)
Attempts to return cached auth tokens that match the given criteria if any have been stored in cache.
Public methodStatic memberTryGetAuthTokens(String, IEnumerableString, SecretKey)
Attempts to return cached auth tokens that match the given criteria if any have been stored in cache.
Public methodStatic memberUpdateOpenIDConnectTokenAsync
Updates an OpenID Connect token so that it contains the latest user information by contacting the Rhino Account's server userinfo endpoint using a compatible O
Top
See Also