Click or drag to resize

IZooClientUtilities Methods

The IZooClientUtilities type exposes the following members.

Methods
  NameDescription
Public methodAskUserForLicense
Public methodCheckInLicense
Checks in a checked out license to the owning Zoo.
Public methodCheckOutLicense
Checks out a loaned out license from the owning Zoo.
Public methodConvertLicense
Converts a standalone license to a network license.
Public methodDeleteLicense
31-Mar-2015 Dale Fugier, http://mcneel.myjetbrains.com/youtrack/issue/MR-1725 Deletes a license along with its license file.
Public methodEcho
Public methodGetCurrentTime
Gets the current time, trying to access an NTP server before using local time.
Public methodGetLicense
Public methodGetLicenseStatus
Returns the current status of every license for ui purposes
Public methodGetLicenseType
Returns the type of a specified product license
Public methodGetOneLicenseStatus
Returns the current status of a license for ui purposes
Public methodGetRegisteredOwnerInfo
Returns the registered owner and organization of a license 4-Sept-2014 Dale Fugier, http://mcneel.myjetbrains.com/youtrack/issue/RH-28623
Public methodInitialize
Public methodIsCheckOutEnabled
Returns whether or not license checkout is enabled
Public methodLicenseOptionsHandler
Public methodLoginToCloudZoo
Logs the user in to the cloud zoo. This logs out the current user and voids any existing leases.
Public methodLogoutOfCloudZoo
Logs the user out of the cloud zoo. This logs out the current user and voids any existing leases.
Public methodReturnLicense(Object, Guid)
Public methodReturnLicense(Object, String, Guid)
Public methodShowBuyLicenseUi
Public methodShowLicenseValidationUi
Shows user interface to validate and register a license. Returns true if the license is successfully validated; false otherwise
Public methodShowRhinoExpiredMessage
Top
See Also