Click or drag to resize

LicenseUtils Methods

The LicenseUtils type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAskUserForLicense(Int32, Boolean, Object, String, ValidateProductKeyDelegate, OnLeaseChangedDelegate, String, String, Guid, Guid, LicenseCapabilities)
This version of Rhino.PlugIns.LicenseUtils.AskUserForLicense is used by Rhino C++ plug-ins.
Public methodStatic memberAskUserForLicense(Int32, Boolean, Object, String, ValidateProductKeyDelegate, OnLeaseChangedDelegate, VerifyLicenseKeyDelegate, VerifyPreviousVersionLicenseDelegate, String, String, Guid, Guid, LicenseCapabilities)
Public methodStatic memberCheckInLicense
Checks in a previously checked out license to the Zoo server from which it was checked out.
Public methodStatic memberCheckOutLicense
Checks out a license that is on loan from a Zoo server on a permanent basis.
Public methodStatic memberConvertLicense
Converts a product license from a standalone node to a network node.
Public methodStatic memberDeleteLicense
Deletes a license along with its license file.
Public methodStatic memberEcho
Test connectivity with the Zoo.
Public methodStatic memberGetLicense(ValidateProductKeyDelegate, OnLeaseChangedDelegate, Int32, Int32, String, String, String, Guid, Guid)
This version of Rhino.PlugIns.LicenseUtils.GetLicense is used by Rhino C++ plug-ins.
Public methodStatic memberGetLicense(ValidateProductKeyDelegate, OnLeaseChangedDelegate, VerifyLicenseKeyDelegate, VerifyPreviousVersionLicenseDelegate, Int32, Int32, String, String, String, Guid, Guid)
Public methodStatic memberGetLicenseCapabilities
Converts an integer to a LicenseCapabilities flag
Public methodStatic memberGetLicenseStatus
Returns the current status of every license for UI purposes.
Public methodStatic memberGetLicenseType
Returns the contentType of a specified product license
Public methodStatic memberGetOneLicenseStatus
Returns the current status of a license for UI purposes.
Public methodStatic memberInitialize
Initializes the license manager.
Public methodStatic memberIsCheckOutEnabled
Returns whether or not license checkout is enabled.
Public methodStatic memberLicenseOptionsHandler
Public methodStatic memberLoginToCloudZoo
Public methodStatic memberLogoutOfCloudZoo
Public methodStatic memberReturnLicense
OBSOLETE - REMOVE WHEN POSSIBLE.
Public methodStatic memberShowBuyLicenseUi
Public methodStatic memberShowLicenseValidationUi
ShowLicenseValidationUi
Public methodStatic memberShowRhinoExpiredMessage
Show Rhino or Beta expired message
Top
See Also