Click or drag to resize

Cylinder Methods

The Cylinder type exposes the following members.

Methods
  NameDescription
Public methodCircleAt
Compute the circle at the given elevation parameter.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodLineAt
Compute the line at the given angle parameter. This line will be degenerate if the cylinder is infinite.
Public methodCode exampleToBrep
Constructs a Brep representation of this Cylinder. This is synonymous with calling NurbsSurface.CreateFromCylinder().
Public methodToNurbsSurface
Constructs a Nurbs surface representation of this cylinder. This is synonymous with calling NurbsSurface.CreateFromCylinder().
Public methodToRevSurface
Constructs a RevSurface representation of this Cylinder. This is synonymous with calling RevSurface.CreateFromCylinder().
Top
See Also