Click or drag to resize

TextLog Methods

The TextLog type exposes the following members.

Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberNewCommandLine
Returns a reference to a TextLog that prints to the Rhino command line. Each new command line reference holds its own indents.
Public methodCode examplePopIndent
Decrease the indentation level
Public methodCode examplePrint(String)
Send text to the text log
Public methodPrint(String, Object)
Send formatted text to the text log
Public methodPrint(String, Object, Object)
Send formatted text to the text log
Public methodPrintWrappedText
Send text wrapped at a set line length
Public methodCode examplePushIndent
Increase the indentation level
Public methodToString
If the TextLog was constructed using the empty constructor, then the text information is stored in a runtime string. The contents of this string is retrieved using ToString for this case
(Overrides ObjectToString.)
Top
See Also