Click or drag to resize

FilePdf Methods

The FilePdf type exposes the following members.

Methods
  NameDescription
Public methodAddPage(ViewCaptureSettings)
Add a new page to this document and draw a viewport into it based on provided ViewCaptureSettings
Public methodAddPage(Int32, Int32, Int32)
Add a blank page to this document
Public methodStatic memberCreate
Create a new instance of a FilePdf class
Public methodDrawBitmap
Draw a bitmap
Public methodDrawLine
Draw a line
Public methodDrawPolyline
Draw a polyline path
Public methodDrawText
Draw text on a page
Protected methodFirePreWriteEvent
Called by the framework to fire a PreWrite event
Public methodPdfDocumentImplementation
Get actual implementation of PdfDocument class
Public methodStatic memberRead
Read a PDF file into a RhinoDoc
Public methodWrite(Stream)
Write PDF to a stream
Public methodWrite(String)
Write PDF to a file
Top
See Also