Click or drag to resize

DracoCompression Methods

The DracoCompression type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCompress(Mesh)
Compress a mesh using default compression options.
Public methodStatic memberCompress(PointCloud)
Compress a point cloud
Public methodStatic memberCompress(Mesh, DracoCompressionOptions)
Compress a mesh
Public methodStatic memberCompress(PointCloud, DracoCompressionOptions)
Compress a point cloud
Public methodStatic memberDecompressBase64String
Decompress base64 encoded version of Draco data into either a mesh or point cloud
Public methodStatic memberDecompressByteArray
Decompress data into either a mesh or point cloud.
Public methodStatic memberDecompressFile
Read compressed data from disk and decompress to RhinoCommon geometry
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Finalizer for DracoCompression
(Overrides ObjectFinalize.)
Public methodToBase64String
Convert byte array of Draco compressed data into a base64 encoded string
Public methodToByteArray
Gets the Draco compressed data as a byte array
Public methodWrite
Write the compressed data to disk
Top
See Also