Vector3dVectorAngle Method (Vector3d, Vector3d) |
Compute the angle between two vectors.
This operation is commutative.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static double VectorAngle(
Vector3d a,
Vector3d b
)
Public Shared Function VectorAngle (
a As Vector3d,
b As Vector3d
) As Double
Parameters
- a
- Type: Rhino.GeometryVector3d
First vector for angle. - b
- Type: Rhino.GeometryVector3d
Second vector for angle.
Return Value
Type:
DoubleIf the input is valid, the angle (in radians) between a and b; RhinoMath.UnsetValue otherwise.
See Also