Click or drag to resize

Vector3dIsParallelTo Method (Vector3d, Double)

Determines whether this vector is parallel to another vector, within a provided tolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int IsParallelTo(
	Vector3d other,
	double angleTolerance
)

Parameters

other
Type: Rhino.GeometryVector3d
Vector to use for comparison.
angleTolerance
Type: SystemDouble
Angle tolerance (in radians).

Return Value

Type: Int32
Parallel indicator:

+1 = both vectors are parallel.

0 = vectors are not parallel or at least one of the vectors is zero.

-1 = vectors are anti-parallel.

See Also