Click or drag to resize

TransformDiagonal Method (Double, Double, Double)

Constructs a new transformation with diagonal (d0,d1,d2,1.0).

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.12
Syntax
public static Transform Diagonal(
	double d0,
	double d1,
	double d2
)

Parameters

d0
Type: SystemDouble
Transform.M00 value.
d1
Type: SystemDouble
Transform.M11 value.
d2
Type: SystemDouble
Transform.M22 value.

Return Value

Type: Transform
A transformation with diagonal (d0,d1,d2,1.0).
See Also