Click or drag to resize

RevSurfaceCreate Method (Polyline, Line, Double, Double)

Constructs a new surface of revolution from a generatrix polyline and an axis.

This overload accepts a slice start and end angles.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static RevSurface Create(
	Polyline revolutePolyline,
	Line axisOfRevolution,
	double startAngleRadians,
	double endAngleRadians
)

Parameters

revolutePolyline
Type: Rhino.GeometryPolyline
A generatrix.
axisOfRevolution
Type: Rhino.GeometryLine
An axis.
startAngleRadians
Type: SystemDouble
An angle in radians for the start.
endAngleRadians
Type: SystemDouble
An angle in radians for the end.

Return Value

Type: RevSurface
A new surface of revolution, or null if any of the inputs is invalid or on error.
See Also