Click or drag to resize

Quaternion Constructor

Initializes a new quaternion with the provided coefficients.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Quaternion(
	double a,
	double b,
	double c,
	double d
)

Parameters

a
Type: SystemDouble
A number. This is the real part.
b
Type: SystemDouble
Another number. This is the first coefficient of the imaginary part.
c
Type: SystemDouble
Another number. This is the second coefficient of the imaginary part.
d
Type: SystemDouble
Another number. This is the third coefficient of the imaginary part.
See Also