Click or drag to resize

Quaternion Properties

The Quaternion type exposes the following members.

Properties
  NameDescription
Public propertyA
Gets or sets the real part of the quaternion.
Public propertyB
Gets or sets the first imaginary coefficient of the quaternion.
Public propertyC
Gets or sets the second imaginary coefficient of the quaternion.
Public propertyConjugate
Gets a new quaternion that is the conjugate of this quaternion.

This is (a,-b,-c,-d)

Public propertyD
Gets or sets the third imaginary coefficient of the quaternion.
Public propertyStatic memberI
Returns the (0,1,0,0) quaternion.
Public propertyStatic memberIdentity
Returns the (1,0,0,0) quaternion.
Public propertyInverse
Computes a new inverted quaternion,

(a/L2, -b/L2, -c/L2, -d/L2),

where L2 = length squared = (a*a + b*b + c*c + d*d).

This is the multiplicative inverse, i.e., (a,b,c,d)*(a/L2, -b/L2, -c/L2, -d/L2) = (1,0,0,0). If this is the zero quaternion, then the zero quaternion is returned.
Public propertyIsScalar
true if b, c, and d are all zero.
Public propertyIsValid
Determines if the four coefficients are valid numbers within RhinoCommon.

See IsValidDouble(Double).

Public propertyIsVector
true if a = 0 and at least one of b, c, or d is not zero.
Public propertyIsZero
true if a, b, c, and d are all zero.
Public propertyStatic memberJ
Returns the (0,0,1,0) quaternion.
Public propertyStatic memberK
Returns the (0,0,0,1) quaternion.
Public propertyLength
Returns the length or norm of the quaternion.
Public propertyLengthSquared
Gets the result of (a^2 + b^2 + c^2 + d^2).
Public propertyScalar
The real (scalar) part of the quaternion

This is A.

Public propertyVector
The imaginary part of the quaternion

(B,C,D)

Public propertyStatic memberZero
Returns the default quaternion, where all coefficients are 0.
Top
See Also