Click or drag to resize

NurbsCurveCreateSubDFriendly Method (Curve)

Create a NURBS curve, that is suitable for calculations like lofting SubD objects, from an existing curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public static NurbsCurve CreateSubDFriendly(
	Curve curve
)

Parameters

curve
Type: Rhino.GeometryCurve
Curve to rebuild as a SubD friendly curve.

Return Value

Type: NurbsCurve
A SubD friendly NURBS curve is successful, null otherwise.
See Also