Click or drag to resize

MatrixMultiply Operator

Multiplies two matrices and returns a new product matrix.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Matrix operator *(
	Matrix a,
	Matrix b
)

Parameters

a
Type: Rhino.GeometryMatrix
A first matrix to use in calculation.
b
Type: Rhino.GeometryMatrix
Another matrix to use in calculation.

Return Value

Type: Matrix
The product matrix.
Exceptions
ExceptionCondition
ArgumentException When a.ColumnCount != b.RowCount.
See Also