Click or drag to resize

MatrixAddition Operator

Adds two matrices and returns a new sum matrix.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static Matrix operator +(
	Matrix a,
	Matrix b
)

Parameters

a
Type: Rhino.GeometryMatrix
A first matrix to use in calculation.
b
Type: Rhino.GeometryMatrix
Another matrix to use in calculation.

Return Value

Type: Matrix
The sum matrix.
Exceptions
ExceptionCondition
ArgumentException When the two matrices are not the same size.
See Also