Click or drag to resize

IntersectionRayShoot Method (IEnumerableGeometryBase, Ray3d, Int32)

Computes point intersections that occur when shooting a ray to a collection of surfaces and Breps.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public static RayShootEvent[] RayShoot(
	IEnumerable<GeometryBase> geometry,
	Ray3d ray,
	int maxReflections
)

Parameters

geometry
Type: System.Collections.GenericIEnumerableGeometryBase
The collection of surfaces and Breps to intersect. Trims are ignored on Breps.
ray
Type: Rhino.GeometryRay3d
>A ray used in intersection.
maxReflections
Type: SystemInt32
The maximum number of reflections. This value should be any value between 1 and 1000, inclusive.

Return Value

Type: RayShootEvent
An array of RayShootEvent structs if successful, or an empty array on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptiongeometry is null.
ArgumentOutOfRangeExceptionmaxReflections is strictly outside the [1-1000] range.
See Also