Click or drag to resize

RayShootEvent Structure

Represents an element which is part of a ray shoot.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public struct RayShootEvent

The RayShootEvent type exposes the following members.

Properties
  NameDescription
Public propertyBrepFaceIndex
If GeometryIndex references a Brep, then the index of the Brep face that was hit. If GeometryIndex references a surface, than RhinoMath.UnsetIntIndex.
Public propertyGeometryIndex
The index of the surface or Brep that was hit.
Public propertyPoint
The 3d hit point.
Top
Methods
  NameDescription
Top
See Also