Click or drag to resize

IntersectionCurveSurfaceValidate Method (Curve, Surface, Double, Double, Int32, TextLog)

Intersects a curve and a surface.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public static CurveIntersections CurveSurfaceValidate(
	Curve curve,
	Surface surface,
	double tolerance,
	double overlapTolerance,
	out int[] invalidIndices,
	out TextLog textLog
)

Parameters

curve
Type: Rhino.GeometryCurve
Curve for intersection.
surface
Type: Rhino.GeometrySurface
Surface for intersection.
tolerance
Type: SystemDouble
Intersection tolerance. If the curve approaches the surface to within tolerance, an intersection is assumed.
overlapTolerance
Type: SystemDouble
The tolerance with which the curves are tested.
invalidIndices
Type: SystemInt32
The indices in the resulting CurveIntersections collection that are invalid.
textLog
Type: Rhino.FileIOTextLog
A text log that contains tails about the invalid intersection events.

Return Value

Type: CurveIntersections
A collection of intersection events.
See Also