NurbsSurfaceKnotListCreateUniformKnots Method |
Compute a clamped, uniform knot vector based on the current
degree and control point count. Does not change values of control
vertices.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool CreateUniformKnots(
double knotSpacing
)
Public Function CreateUniformKnots (
knotSpacing As Double
) As Boolean
Parameters
- knotSpacing
- Type: SystemDouble
Spacing of subsequent knots.
Return Value
Type:
Booleantrue on success, false on failure.
See Also