MeshFaceListDeleteFaces Method (IEnumerableInt32) |
Removes a collection of faces from the mesh without affecting the remaining geometry.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int DeleteFaces(
IEnumerable<int> faceIndexes
)
Public Function DeleteFaces (
faceIndexes As IEnumerable(Of Integer)
) As Integer
Parameters
- faceIndexes
- Type: System.Collections.GenericIEnumerableInt32
An array containing all the face indices to be removed.
Return Value
Type:
Int32The number of faces deleted on success.
See Also