Rhino C++ API  8.10
Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDComponentRegion Class Reference

#include <opennurbs_subd.h>

Public Types

enum  : unsigned int { TransientIdBit = 0x80000000U }
 

Public Member Functions

 ON_SubDComponentRegion ()=default
 
 ON_SubDComponentRegion (const ON_SubDComponentRegion &)=default
 
 ~ON_SubDComponentRegion ()=default
 
bool IsEmptyRegion () const
 
bool IsPersistentId () const
 
bool IsTransientId () const
 
ON_SubDComponentRegionoperator= (const ON_SubDComponentRegion &)=default
 
void Pop ()
 
void PushAbsolute (unsigned int region_index)
 
void PushAdjusted (unsigned int region_index)
 
void SetLevel0Component (ON_SubDComponentPtr component_ptr)
 
void SetLevel0EdgePtr (const ON_SubDEdgePtr edge_ptr)
 
void SetLevel0Face (const ON_SubDFace *face)
 
void SetLevel0Vertex (const ON_SubDVertex *vertex)
 
unsigned short SubdivisionCount () const
 
const ON_wString ToString () const
 
wchar_t * ToString (wchar_t *s, size_t s_capacity) const
 

Static Public Member Functions

static int Compare (const ON_SubDComponentRegion *lhs, const ON_SubDComponentRegion *rhs)
 
static int CompareTypeIdDirection (const ON_SubDComponentRegion *lhs, const ON_SubDComponentRegion *rhs)
 
static int CompareTypeIdDirectionMinimumSubregion (const ON_SubDComponentRegion *lhs, const ON_SubDComponentRegion *rhs)
 
static int CompareTypeIdDirectionSubregion (const ON_SubDComponentRegion *lhs, const ON_SubDComponentRegion *rhs)
 
static const ON_SubDComponentRegion Create (const class ON_SubDFace *level0_face)
 
static const ON_SubDComponentRegion Create (unsigned int component_id, ON_SubDComponentPtr::Type component_type, bool bComponentMark)
 
static const ON_SubDComponentRegion CreateSubdivisionRegion (ON_SubDComponentPtr::Type component_type, bool bComponentDirection, unsigned short subdivision_count, bool bAssignTransientId)
 
static bool IsPersistentId (unsigned int id)
 
static bool IsTransientId (unsigned int id)
 
static const unsigned int NewTransientId ()
 
static void ResetTransientId ()
 
static unsigned int TransientId (unsigned int id)
 

Public Attributes

ON_SubDComponentPtr m_level0_component = ON_SubDComponentPtr::Null
 
unsigned int m_level0_component_id = 0
 
ON_SubDComponentRegionIndex m_region_index
 

Static Public Attributes

static const ON_SubDComponentRegion Empty