Rhino C++ API  8.10
Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDComponentRegionIndex Class Reference

#include <opennurbs_subd.h>

Public Types

enum  : unsigned short { IndexCapacity = 9 }
 

Public Member Functions

 ON_SubDComponentRegionIndex ()=default
 
 ON_SubDComponentRegionIndex (const ON_SubDComponentRegionIndex &)=default
 
 ~ON_SubDComponentRegionIndex ()=default
 
unsigned short Index (unsigned short i) const
 
ON_SubDComponentRegionIndexoperator= (const ON_SubDComponentRegionIndex &)=default
 
void Pop ()
 
void Push (unsigned int region_index)
 
ON__UINT32 ToCompressedRegionIndex () const
 
const ON_wString ToString () const
 
wchar_t * ToString (wchar_t *s, size_t s_capacity) const
 

Static Public Member Functions

static int Compare (const ON_SubDComponentRegionIndex *lhs, const ON_SubDComponentRegionIndex *rhs)
 
static int CompareMinimumSubregion (const ON_SubDComponentRegionIndex *lhs, const ON_SubDComponentRegionIndex *rhs)
 
static const ON_SubDComponentRegionIndex FromCompressedRegionIndex (ON__UINT32 compressed_region_index)
 
static void FromCompressedRegionIndex (ON__UINT32 compressed_region_index, unsigned short *subdivision_count, unsigned short *region_index)
 
static ON__UINT32 ToCompressedRegionIndex (unsigned short subdivision_count, const unsigned short *region_index)
 

Public Attributes

unsigned short m_index [ON_SubDComponentRegionIndex::IndexCapacity] = {}
 
unsigned short m_subdivision_count = 0
 

Static Public Attributes

static const ON_SubDComponentRegionIndex Unset
 All values are 0xFFFF. More...
 
static const ON_SubDComponentRegionIndex Zero
 All values are zero. More...