Rhino C++ API  8.10
Public Member Functions | List of all members
ON_SubDComponentPtrPairHashTable Class Reference

#include <opennurbs_subd.h>

Inheritance diagram for ON_SubDComponentPtrPairHashTable:
ON_Hash32Table

Public Member Functions

 ON_SubDComponentPtrPairHashTable ()
 
 ON_SubDComponentPtrPairHashTable (const class ON_SubD &subd)
 This is a good choice of constructor when the hash table is used to find pairs of vertices and edges. More...
 
 ON_SubDComponentPtrPairHashTable (size_t pair_count_estimate)
 This is a good choice of constructor when you have a good estimate of the number of pairs that will be in the hash table. More...
 
 ~ON_SubDComponentPtrPairHashTable ()=default
 
bool AddComponentPair (ON_SubDComponentPtr first_component, ON_SubDComponentPtr second_component)
 
bool AddEdgePair (const class ON_SubDEdge *first_e, const class ON_SubDEdge *second_e)
 
bool AddEdgePair (const class ON_SubDEdge *first_e, const ON_SubDEdgePtr second_eptr)
 
bool AddFacePair (const class ON_SubDFace *first_f, const class ON_SubDFace *second_f)
 
bool AddVertexPair (const class ON_SubDVertex *first_v, const class ON_SubDVertex *second_v)
 
const ON_SubDComponentPtrPair PairFromSecondComponentPtr (ON_SubDComponentPtr second_component)
 
const ON_SubDComponentPtrPair PairFromSecondEdge (const class ON_SubDEdge *second_e)
 
const ON_SubDComponentPtrPair PairFromSecondFace (const class ON_SubDFace *second_f)
 
const ON_SubDComponentPtrPair PairFromSecondVertex (const class ON_SubDVertex *second_v)