Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDComponentPtrPair Class Reference

#include <opennurbs_subd.h>

Public Member Functions

bool BothAreNotNull () const
 
bool BothAreNull () const
 
ON_SubDComponentPtr::Type ComponentType () const
 
const ON_SubDComponentPtr First () const
 
bool FirstIsNotNull () const
 
bool FirstIsNull () const
 
const ON_SubDComponentPtrPair ReversedPair () const
 
const ON_SubDComponentPtr Second () const
 
bool SecondIsNotNull () const
 
bool SecondIsNull () const
 
const ON_SubDComponentPtrPair SwapPair () const
 

Static Public Member Functions

static int CompareComponent (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs)
 
static int CompareComponentAndDirection (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs)
 
static int CompareFirstPointer (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs)
 
static const ON_SubDComponentPtrPair Create (ON_SubDComponentPtr first_ptr, ON_SubDComponentPtr second_ptr)
 

Public Attributes

ON_SubDComponentPtr m_pair [2]
 

Static Public Attributes

static const ON_SubDComponentPtrPair Null