Rhino C++ API  8.10
Public Member Functions | List of all members
ON_SubDComponentIdList Class Reference

#include <opennurbs_subd.h>

Inheritance diagram for ON_SubDComponentIdList:
ON_SubDComponentTest

Public Member Functions

 ON_SubDComponentIdList ()=default
 
 ON_SubDComponentIdList (const ON_SubDComponentIdList &)=default
 
 ~ON_SubDComponentIdList ()=default
 
void AddId (ON_SubDComponentId cid)
 
void AddId (ON_SubDComponentPtr cptr)
 
void AddIdList (const ON_SubDComponentIdList &list)
 
bool InList (ON_SubDComponentId cid) const
 
bool InList (ON_SubDComponentPtr cptr) const
 
bool InListPassesResult () const
 Value Passes(cptr) returns when cptr is in the list. More...
 
ON_SubDComponentIdListoperator= (const ON_SubDComponentIdList &)=default
 
ON_SubDComponentId operator[] (unsigned int i) const
 
bool Passes (const ON_SubDComponentPtr cptr) const override
 
void SetInListPassesResult (bool bInListPassesResult)
 
unsigned int UnsignedCount () const
 
- Public Member Functions inherited from ON_SubDComponentTest
 ON_SubDComponentTest ()=default
 
 ON_SubDComponentTest (const ON_SubDComponentTest &)=default
 
 ON_SubDComponentTest (ON__UINT_PTR ptr)
 
virtual ~ON_SubDComponentTest ()
 
ON_SubDComponentTestoperator= (const ON_SubDComponentTest &)=default
 
bool Passes (const class ON_SubDEdge *e) const
 
bool Passes (const class ON_SubDFace *f) const
 
bool Passes (const class ON_SubDVertex *v) const
 

Additional Inherited Members

- Static Public Attributes inherited from ON_SubDComponentTest
static const ON_SubDComponentTest AllFail
 Passes() returns false for every component. More...
 
static const ON_SubDComponentTest AllPass
 Passes() returns true for every non nullptr component. More...
 
- Protected Attributes inherited from ON_SubDComponentTest
ON__UINT_PTR m_ptr = 0
 classes derived from ON_SubDVertexFilter may use m_ptr as they see fit including to completely ignore it. More...