Rhino C++ API  8.10
Public Member Functions | Static Public Attributes | Protected Attributes | List of all members
ON_SubDComponentTest Class Reference

#include <opennurbs_subd.h>

Inheritance diagram for ON_SubDComponentTest:
ON_SubDComponentIdList

Public Member Functions

 ON_SubDComponentTest ()=default
 
 ON_SubDComponentTest (const ON_SubDComponentTest &)=default
 
 ON_SubDComponentTest (ON__UINT_PTR ptr)
 
virtual ~ON_SubDComponentTest ()
 
ON_SubDComponentTestoperator= (const ON_SubDComponentTest &)=default
 
bool Passes (const class ON_SubDEdge *e) const
 
bool Passes (const class ON_SubDFace *f) const
 
bool Passes (const class ON_SubDVertex *v) const
 
virtual bool Passes (const ON_SubDComponentPtr cptr) const
 

Static Public Attributes

static const ON_SubDComponentTest AllFail
 Passes() returns false for every component. More...
 
static const ON_SubDComponentTest AllPass
 Passes() returns true for every non nullptr component. More...
 

Protected Attributes

ON__UINT_PTR m_ptr = 0
 classes derived from ON_SubDVertexFilter may use m_ptr as they see fit including to completely ignore it. More...
 

Detailed Description

ON_SubDComponentTest Description: ON_SubDComponentTest is used in contexts where custom testing or filtering of SubD components is required.