ModelEarthAnchorPoint Class |
Namespace: Grasshopper.Rhinoceros.Model
The ModelEarthAnchorPoint type exposes the following members.
Name | Description | |
---|---|---|
![]() | ModelEarthAnchorPoint | Initializes a new instance of the ModelEarthAnchorPoint class |
![]() | ModelEarthAnchorPoint(ModelEarthAnchorPointAttributes) | Initializes a new instance of the ModelEarthAnchorPoint class |
![]() | ModelEarthAnchorPoint(EarthAnchorPoint) | Initializes a new instance of the ModelEarthAnchorPoint class |
Name | Description | |
---|---|---|
![]() | Elevation |
Gets a point elevation on earth, in meters.
|
![]() | ElevationCoordinateSystem |
Gets the value indicating the zero level convention relating to a location on Earth
|
![]() | Id | (Inherited from ModelContent.) |
![]() | IsValid | (Inherited from ModelContent.) |
![]() | Latitude |
Gets a point latitude on earth, in degrees. [-90, +90]
|
![]() | Longitude |
Gets a point longitude on earth, in degrees. [-180, +180]
|
![]() | ModelCompass |
Gets the corresponding compass plane in model coordinates
|
![]() | Name | (Inherited from ModelContent.) |
![]() | Notes | (Inherited from ModelContent.) |
![]() | Parent | (Inherited from ModelContent.) |
![]() | Path | (Inherited from ModelContent.) |
![]() | Tags | (Inherited from ModelContent.) |
Name | Description | |
---|---|---|
![]() ![]() | Cast | |
![]() | CastToT(T) | (Overrides ModelContentCastToT(T).) |
![]() | CastToT(T) | (Inherited from ModelContent.) |
![]() | CastToT(T) | (Inherited from ModelData.) |
![]() | Equals(ModelContent) | (Inherited from ModelContent.) |
![]() | Equals(ModelData) | (Inherited from ModelData.) |
![]() | Equals(Object) | (Inherited from ModelContent.) |
![]() | GetHashCode | (Inherited from ModelContent.) |
![]() | ToAttributes | |
![]() | ToDetails | (Inherited from ModelData.) |
![]() | TooltipString | (Overrides ModelContentTooltipString.) |
![]() | ToString | (Overrides ModelContentToString.) |
Name | Description | |
---|---|---|
![]() ![]() | (ModelEarthAnchorPointAttributes to ModelEarthAnchorPoint) | |
![]() ![]() | (EarthAnchorPoint to ModelEarthAnchorPoint) |