ModelView Class |
Namespace: Grasshopper.Rhinoceros.Display
The ModelView type exposes the following members.
Name | Description | |
---|---|---|
ModelView | Initializes a new instance of the ModelView class | |
ModelView(Guid) |
Create a new referenced view that references a RhinoView or NamedView object with the specified ref_guid.
| |
ModelView(ModelView) | Initializes a new instance of the ModelView class | |
ModelView(RhinoView) | Initializes a new instance of the ModelView class | |
ModelView(RhinoViewport) | Initializes a new instance of the ModelView class | |
ModelView(ViewInfo) | Initializes a new instance of the ModelView class | |
ModelView(ViewportInfo) | Initializes a new instance of the ModelView class | |
ModelView(ViewportInfo, String) | Initializes a new instance of the ModelView class |
Name | Description | |
---|---|---|
Cast | ||
CastToQ | ||
Equals(ModelView) | ||
Equals(Object) | (Overrides ObjectEquals(Object).) | |
EqualsViewportInfo | ||
GetBoundingBox | ||
GetHashCode | (Overrides ObjectGetHashCode.) | |
Morph | ||
ToString | (Overrides ObjectToString.) | |
ToViewportInfo | ||
Transform |