GH_RotationalTuningDataT Class |
Namespace: Grasshopper.GUI
The GH_RotationalTuningDataT type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_RotationalTuningDataT(T, PointF) |
Create a new instance of the rotational tuning data.
|
![]() | GH_RotationalTuningDataT(T, PointF, PointF) |
Create a new instance of the rotational tuning data.
|
Name | Description | |
---|---|---|
![]() | Frame |
Gets the frame at the given index.
|
![]() | FrameCount |
Gets the total number of recorded frames.
|
![]() | InitialValue |
Gets the initial value.
|
![]() | Pivot |
Gets or sets the rotational pivot. You only need to set this if the pivot changes.
|
Name | Description | |
---|---|---|
![]() | AddFrame |
Grow the tuning track by one point and compute the angle.
|
![]() | TotalAngle |
Compute the total angle from the first to the last frame.
|
![]() | TotalTurns |
Compute the total number of full turns from the first to the last frame.
|