GH_IChunk Interface |
Namespace: GH_IO.Serialization
The GH_IChunk type exposes the following members.
Name | Description | |
---|---|---|
![]() | Archive |
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
|
![]() | ArchiveLocation |
Gets a string representing the URI with which the archive is associated.
The location may be a null string.
|
![]() | ChunkCount |
Gets the number of child chunks contained in this chunk.
The set of all child chunks is referred to as a 'litter'.
|
![]() | Chunks |
Gets a pointer to the internal list of child chunks.
Do not access this list unless you know what you are doing.
|
![]() | Index |
Gets the index of this chunk. The index is set by the owner of this chunk.
Indices smaller than zero imply no index has been set.
The combination of name+index is always unique among a set of chunks in the same litter.
|
![]() | ItemCount |
Gets the number of items contained in this chunk.
|
![]() | Items |
Gets a pointer to the internal list of items.
Do not access this list unless you know what you are doing.
|
![]() | Name |
Gets the name of this chunk. The name is set by the owner of this chunk.
Names must be at least 1 character long.
The combination of name+index is always unique among a set of chunks in a single litter.
|
Name | Description | |
---|---|---|
![]() | AddMessage |
Log a new message with the top-level archive.
Messages are collected during read/write operations,
and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
|
![]() | Read(BinaryReader) |
Called when an object is required to deserialize itself.
(Inherited from GH_IBinarySupport.) |
![]() | Read(XmlNode) |
Called when an object is required to deserialize itself.
(Inherited from GH_IXmlSupport.) |
![]() | Write(BinaryWriter) |
Called when an object is required to serialize itself.
(Inherited from GH_IBinarySupport.) |
![]() | Write(XmlWriter) |
Called when an object is required to serialize itself.
(Inherited from GH_IXmlSupport.) |