GH_IChunk Methods |
The GH_IChunk type exposes the following members.
Name | Description | |
---|---|---|
![]() | AddMessage |
Log a new message with the top-level archive.
Messages are collected during read/write operations,
and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
|
![]() | Read(BinaryReader) |
Called when an object is required to deserialize itself.
(Inherited from GH_IBinarySupport.) |
![]() | Read(XmlNode) |
Called when an object is required to deserialize itself.
(Inherited from GH_IXmlSupport.) |
![]() | Write(BinaryWriter) |
Called when an object is required to serialize itself.
(Inherited from GH_IBinarySupport.) |
![]() | Write(XmlWriter) |
Called when an object is required to serialize itself.
(Inherited from GH_IXmlSupport.) |