GH_ParamT Properties |
The GH_ParamT generic type exposes the following members.
Name | Description | |
---|---|---|
Access |
Gets or sets the Access level for this parameter.
| |
Attributes |
Gets or sets the attributes that are associated with this object.
Only set custom attributes if you know what you are doing.
(Inherited from GH_DocumentObject.) | |
Category |
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
(Inherited from GH_InstanceDescription.) | |
ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
ID that is used to identify objects of the same type.
(Inherited from GH_DocumentObject.) | |
DataMapping |
Gets or sets the data mapping of this Parameter.
| |
DataType |
Type is either Void if there are no sources or Remote. Derived classes should expand on this.
| |
Description |
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from GH_InstanceDescription.) | |
Exposure |
Gets the exposure of this object in the Graphical User Interface.
The default is to expose everywhere.
(Inherited from GH_DocumentObject.) | |
HasCategory |
Gets whether or not the Category field has been set.
(Inherited from GH_InstanceDescription.) | |
HasProxySources |
Gets a value indicating whether or not this parameter maintains proxy sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
HasSubCategory |
Gets whether or not the SubCategory field has been set.
(Inherited from GH_InstanceDescription.) | |
Icon |
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached,
so don't worry if icon retrieval is not very fast.
(Inherited from GH_DocumentObject.) | |
Icon_24x24 |
The icon associated with this object.
(Inherited from GH_DocumentObject.) | |
Icon_24x24_Locked |
The greyscale icon of this object.
(Inherited from GH_DocumentObject.) | |
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
and return False.
(Inherited from GH_ActiveObject.) | |
IconDisplayMode |
Gets the current display mode of the object.
(Inherited from GH_DocumentObject.) | |
InstanceDescription |
Gets the description of this instance. The default description is about the amount and source of the local values.
(Overrides GH_InstanceDescriptionInstanceDescription.) | |
InstanceGuid |
Gets the ID of this runtime instance.
(Inherited from GH_InstanceDescription.) | |
IsDataProvider | (Overrides GH_ActiveObjectIsDataProvider.) | |
IsPrincipal |
Gets whether this parameter is a principal parameter.
Principal parameters are maintained by components and are not part of the IGH_Param interface.
| |
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
can override this property to aid in object searches.
(Inherited from GH_InstanceDescription.) | |
Kind |
Gets the parameter kind. The kind is evaluated lazily and cached.
| |
Locked |
Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
(Inherited from GH_ActiveObject.) | |
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
The default is TRUE.
(Inherited from GH_ActiveObject.) | |
Name |
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from GH_InstanceDescription.) | |
NickName |
Gets or sets the nickname of the object. This field can be changed by the user.
(Inherited from GH_InstanceDescription.) | |
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
ObsoleteAttribute.
You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
(Inherited from GH_DocumentObject.) | |
Optional |
Gets or sets whether or not this parameter is considered optional by the owner component.
Empty, non-optional parameters prevent the component from being solved.
| |
Phase |
Gets or sets the solution phase this object is currenly in.
(Inherited from GH_ActiveObject.) | |
ProcessorTime | (Overrides GH_ActiveObjectProcessorTime.) | |
ProxySourceCount |
Gets the number of proxy sources for this parameter.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
Recipients |
Gets a list of all the recipients of this parameter.
I.e. a recipient has this parameter as one of the sources.
The Recipient list is maintained by the parameter,
do not modify it yourself.
| |
Reverse |
Gets or sets the data reverse modifier of this parameter.
| |
RuntimeMessageLevel |
Returns the worst case flag for the current object
(Inherited from GH_ActiveObject.)If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. | |
Simplify |
Gets or sets the simplify modifier for this parameter.
| |
SourceCount |
Gets the number of sources for this parameter.
| |
Sources |
Gets a list of source parameters. Do not modify this list,
if you wish to add or remove sources, use dedicated functions
like AddSource() and RemoveSource() instead.
| |
StateTags |
Gets all the StateTags that are associated with this parameter.
A state tag is a visual feedback icon that represents specific internal settings.
| |
SubCategory |
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
(Inherited from GH_InstanceDescription.) | |
Type |
Gets the Framework Type descriptor for the stored Data.
| |
TypeName |
Calls TypeName() on the first instance of T it can find.
This is either an item in the volatile list, or a newly constructed instance.
| |
VolatileData | ||
VolatileDataCount | ||
WireDisplay |
Gets or sets the wire display style for this parameter.
Wire display only affects the wires connected to the parameter input.
|