NullParamAttributes Methods |
The GH_ComponentParamServerNullParamAttributes type exposes the following members.
Name | Description | |
---|---|---|
ExpireLayout |
Expires the entire layout of the attributes. When overridden,
InvalidateCanvas |
If the mouse location should cause a canvas invalidation then return true.
You only need to override this function if you draw objects that are dependant
IsMenuRegion |
Determines whether a point is available for context menu popups.
IsPickRegion(PointF) |
Determines whether a point is within the pickable region for this object.
IsPickRegion(RectangleF, GH_PickBox) |
Determines whether a rectangle is a valid pick region for this object.
IsTooltipRegion |
Determines whether a point is available for tooltip popups.
Layout |
Perform dedicated layout logic specific to this particular DocumentObject.
NewInstanceGuid(Guid) |
Generate a new instance GUID for the owner object. Do not use this overload
PerformLayout |
Recompute the layout for these attributes. This function is automatically called during
PrepareForRender |
This method will always be called exactly once prior to Render().
RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, GH_ParamWireDisplay) |
Utility function for derived classes. This method draws all the wires going into the
RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, IEnumerablePen) |
Utility function for derived classes. This method draws all the wires going into the
RenderToCanvas |
Render these attributes into a Canvas control. This function places calls to
SetupTooltip |
Populates the Grasshopper tooltip with all relevant data.
If this function returns True, it is assumed that all possible
Write | (Overrides GH_AttributesTWrite(GH_IWriter).) |