Click or drag to resize

ToolbarFileCollection Class

Represents a collection of Rhino toolbars, or .RUI, files.
Inheritance Hierarchy
SystemObject
  Rhino.UIToolbarFileCollection

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public sealed class ToolbarFileCollection : IEnumerable<ToolbarFile>, 
	IEnumerable

The ToolbarFileCollection type exposes the following members.

Properties
  NameDescription
Public propertyCount
Get tne number of open toolbar files.
Public propertyItem
Gets an open toolbar file by index.
Public propertyStatic memberMruSidebarIsVisible
Returns true if the most-recently-used sizebar is visible.
Public propertyStatic memberSidebarIsVisible
Returns true if the sizebar is visible.
Top
Methods
  NameDescription
Public methodFindByName
Gets an open toolbar file by name, or alias.
Public methodFindByPath
Gets an open toolbar by full path.
Public methodGetEnumerator
Gets a toolbar file enumerator.
Public methodOpen
Opens a toolbar file.
Top
See Also