Click or drag to resize

StatusBar Class

Contains static methods to control the application status bar.
Inheritance Hierarchy
SystemObject
  Rhino.UIStatusBar

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class StatusBar

The StatusBar type exposes the following members.

Methods
  NameDescription
Public methodStatic memberClearMessagePane
Removes the message from the message pane.
Public methodStatic memberHideProgressMeter
Ends, or hides, Rhino's status bar progress meter.
Public methodStatic memberHideProgressMeter(UInt32)
Ends, or hides, Rhino's status bar progress meter.
Public methodStatic memberSetDistancePane
Sets the distance pane to a distance value.
Public methodStatic memberSetMessagePane
Sets the message pane to a message.
Public methodStatic memberSetNumberPane
Sets the number pane to a number value
Public methodStatic memberSetPointPane
Sets the point pane to a point value.
Public methodStatic memberShowProgressMeter(Int32, Int32, String, Boolean, Boolean)
Starts, or shows, Rhino's status bar progress meter.
Public methodStatic memberShowProgressMeter(UInt32, Int32, Int32, String, Boolean, Boolean)
Starts, or shows, Rhino's status bar progress meter.
Public methodStatic memberUpdateProgressMeter(Int32, Boolean)
Sets the current position of Rhino's status bar progress meter.
Public methodStatic memberUpdateProgressMeter(String, Int32, Boolean)
Sets the label and current position of Rhino's status bar progress meter.
Public methodStatic memberUpdateProgressMeter(UInt32, Int32, Boolean)
Sets the current position of Rhino's status bar progress meter.
Public methodStatic memberUpdateProgressMeter(UInt32, String, Int32, Boolean)
Sets the label and current position of Rhino's status bar progress meter.
Top
See Also