Click or drag to resize

RuiUpdateUi Class

[Missing <summary> documentation for "T:Rhino.UI.RuiUpdateUi"]

Inheritance Hierarchy

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RuiUpdateUi : EventArgs

The RuiUpdateUi type exposes the following members.

Properties
  NameDescription
Public propertyChecked
Set to true to enable menu item or false to check menu item
Public propertyEnabled
Set to true to enable menu item or false to disable menu item
Public propertyFileId
Id of the RUI file that owns this menu item
Public propertyMenuHandle
Windows menu handle of menu that contains this item
Public propertyMenuId
Id of the menu that owns this menu item
Public propertyMenuIndex
Zero based index of item in the Windows menu
Public propertyMenuItemId
Id of the menu item that owns this menu item
Public propertyRadioChecked
Set to true to enable menu item or false to check menu item
Public propertyText
Menu item text
Public propertyWindowsMenuItemId
Windows menu item ID
Top
Methods
  NameDescription
Public methodStatic memberRegisterMenuItem(Guid, Guid, Guid, RuiUpdateUiUpdateMenuItemEventHandler)
Register menu item update delegate
Public methodStatic memberRegisterMenuItem(String, String, String, RuiUpdateUiUpdateMenuItemEventHandler)
Register menu item update delegate
Top
See Also