Click or drag to resize

LOC Class

Used a placeholder which is used by LocalizationProcessor application to create contextId mapped localized strings.
Inheritance Hierarchy
SystemObject
  Rhino.UILOC

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class LOC

The LOC type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCOMMANDNAME
Command names that need to be localized should call this function. The COMMANDNAME function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.COMMANDNAME and builds a record for each command name for the translators that can be used by developers in a commands overridden Rhino.Commands.Command.LocalName which should call Rhino.UI.Localization.LocalizeCommandName(EnglishName)
Public methodStatic memberCON(String)
Command option name strings that need to be localized should call this function. The CON function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.CON. The function is then replaced with a call to Localization.LocalizeCommandOptionName using a unique context ID.
Public methodStatic memberCON(String, Int32) Obsolete.
DO NOT use this function, it is a trap to determine where context IDs have been copied from other, already extracted, strings.
Public methodStatic memberCON(String, Object)
Command option name strings that need to be localized should call this function. The CON function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.CON. The function is then replaced with a call to Localization.LocalizeCommandOptionName using a unique context ID.
Public methodStatic memberCOV(String)
Command option name strings that need to be localized should call this function. The COV function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.COV. The function is then replaced with a call to Localization.LocalizeCommandOptionValue using a unique context ID.
Public methodStatic memberCOV(String, Object)
Command option name strings that need to be localized should call this function. The COV function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.COV. The function is then replaced with a call to Localization.LocalizeCommandOptionValue using a unique context ID.
Public methodStatic memberSTR(String)
Strings that need to be localized should call this function. The STR function doesn't actually do anything but return the original string. The LocalizationProcessor application walks through the source code of a project and looks for LOC.STR. The function is then replaced with a call to Localization.LocalizeString using a unique context ID.
Public methodStatic memberSTR(String, Int32) Obsolete.
DO NOT use this function, it is a trap to determine where context IDs have been copied from other, already extracted, strings.
Public methodStatic memberSTR(String, Object)
Similar to Format(String, Object) function.
Top
See Also