Click or drag to resize

GumballObject Class

[Missing <summary> documentation for "T:Rhino.UI.Gumball.GumballObject"]

Inheritance Hierarchy
SystemObject
  Rhino.UI.GumballGumballObject

Namespace:  Rhino.UI.Gumball
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GumballObject : IDisposable

The GumballObject type exposes the following members.

Constructors
  NameDescription
Public methodGumballObject
Initializes a new instance of the GumballObject class
Top
Properties
  NameDescription
Public propertyFrame
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the GumballObject
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the GumballObject and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodSetFromArc
Public methodSetFromBoundingBox(BoundingBox)
Public methodSetFromBoundingBox(Plane, BoundingBox)
Sets the gumball bounding box with respect to a frame.
Public methodSetFromCircle
Public methodSetFromCurve
Public methodSetFromEllipse
Public methodSetFromExtrusion
Public methodSetFromHatch
Public methodSetFromLight
Public methodSetFromLine
Public methodSetFromPlane
Top
See Also