Click or drag to resize

GumballDisplayConduit Class

[Missing <summary> documentation for "T:Rhino.UI.Gumball.GumballDisplayConduit"]

Inheritance Hierarchy
SystemObject
  Rhino.UI.GumballGumballDisplayConduit

Namespace:  Rhino.UI.Gumball
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GumballDisplayConduit : IDisposable

The GumballDisplayConduit type exposes the following members.

Constructors
  NameDescription
Public methodGumballDisplayConduit Obsolete.
Initializes a new instance of the GumballDisplayConduit class
Public methodGumballDisplayConduit(ActiveSpace)
Initializes a new instance of the GumballDisplayConduit class
Top
Properties
  NameDescription
Public propertyBaseGumball
Starting location.
Public propertyEnabled
Public propertyGumball
Public propertyGumballTransform
The gumball transformation is the transformation calculated by comparing the current gumball to the starting BaseGumball.
Public propertyInRelocate
Public propertyPickResult
The initial mouse down event sets PickResult.
Public propertyPreTransform
The pre-transform is a transformation that needs to be applied before the gumball transformation.
Public propertyTotalTransform
The total transformation is GumballTransform * PreTransform.
Top
Methods
  NameDescription
Public methodCheckShiftAndControlKeys
Public methodDispose
Releases all resources used by the GumballDisplayConduit
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the GumballDisplayConduit and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodPickGumball
Public methodSetBaseGumball(GumballObject)
Contents of the gumball are copied to the base gumball of this class.
Public methodSetBaseGumball(GumballObject, GumballAppearanceSettings)
Contents of the gumball are copied to the base gumball of this class.
Public methodUpdateGumball
Top
See Also