Click or drag to resize

Fonts Class

Rhino.Rumtime.UI
Inheritance Hierarchy
SystemObject
  Rhino.UIFonts

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Fonts

The Fonts type exposes the following members.

Constructors
  NameDescription
Public methodFonts
Initializes a new instance of the Fonts class
Top
Properties
  NameDescription
Public propertyStatic memberBoldHeadingFont
Returns a font that is 1.2x NormalFont and Bold
Public propertyStatic memberHeadingFont
Returns a font used for dialog headings. 1.2x the size of NormalFont.
Public propertyStatic memberNormalFont
Returns the normal font used for dialog boxes and buttons.
Public propertyStatic memberSmallFont
Returns a font use for small text in dialog boxes. 0.8x the size of NormalFont.
Public propertyStatic memberTitleFont
Returns a font used for dialog titles. 2x the size of NormalFont, and bold.
Top
Methods
  NameDescription
Public methodStatic memberGetUiFont
GetUiFont provides access to a set of unmanaged fonts used by Rhino.
Top
See Also