Click or drag to resize

IHeaderButtonHandler Interface

This interface represents a handler for putting custom buttons on the header of IRhinoUiSection.

Namespace:  Rhino.UI.Controls
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface IHeaderButtonHandler

The IHeaderButtonHandler type exposes the following members.

Methods
  NameDescription
Public methodButtonDetails
Implement this method to describe custom buttons on the section header. RDK calls this method continually increasing iIndex until it returns \e false
Public methodButtonRect
Implement this method to get the rectangle of a button on the header window.
Public methodDeleteThis
Public methodOnButtonClicked
Implement this method to handle a button click.
Top
See Also