Click or drag to resize

CollapsibleSectionViewModel Class

Derive from this class to implement your own view model that wraps around a built in implementation of IRdkViewModel. Use GetData etc to implement your properties.
Inheritance Hierarchy
SystemObject
  Rhino.UI.ControlsCollapsibleSectionViewModel

Namespace:  Rhino.UI.Controls
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CollapsibleSectionViewModel : IRdkViewModel, 
	IHasCppImplementation

The CollapsibleSectionViewModel type exposes the following members.

Constructors
  NameDescription
Public methodCollapsibleSectionViewModel
Construct from your section - the view model should be a member of the section
Top
Properties
  NameDescription
Public propertyCppPointer
Top
Methods
  NameDescription
Public methodCommit
Public methodDiscard
Public methodGetData
Call for an interface to data
Public methodUndoHelper
Helper function to ease the use of undo records
Top
See Also