Click or drag to resize

ScaleValue Class

Represents a scale with associated LengthValues and string representations of the scale. This allows for going back and forth from numerical representations of a scale and a string representation without "guessing" at the initial scale.
Inheritance Hierarchy
SystemObject
  RhinoScaleValue

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ScaleValue : IDisposable

The ScaleValue type exposes the following members.

Constructors
  NameDescription
Public methodScaleValue
Default constructor
Top
Properties
  NameDescription
Public propertyLeftToRightScale
LeftLengthValue / RightLengthValue
Public propertyRightToLeftScale
RightLengthValue / LeftLengthValue
Top
Methods
  NameDescription
Public methodStatic memberCreate(String, StringParserSettings)
Create from string
Public methodStatic memberCreate(LengthValue, LengthValue, ScaleValueScaleStringFormat)
Create from 2 length values
Public methodDispose
actively reclaim native allocated ON_SacleValue*
Protected methodFinalize
passively reclaim native allocated ON_ScaleValue*
(Overrides ObjectFinalize.)
Public methodIsUnset
Test IsUnset
Public methodLeftLengthValue
Get the Left LengthValue from Scale
Public methodStatic memberOneToOne
Make a new ScaleValue set to OneToOne
Public methodRightLengthValue
Get the Right LengthValue from Scale
Top
See Also