Click or drag to resize

StdVectorGuid Class

Wrapper for std::vector<ON_UUID>. If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersStdVectorGuid

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class StdVectorGuid : IDisposable

The StdVectorGuid type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCount
Gets the amount of elements in this vector.
Public propertyItem
Get the Guid at index
Top
Methods
  NameDescription
Public methodAppend
Appends a new Guid at the end of this vector.
Public methodConstPointer
Gets the constant (immutable) pointer of this vector.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this vector.
Public methodToArray
Returns the managed counterpart of the unmanaged vector.
Top
See Also