Click or drag to resize

SimpleArrayPoint2d Class

ON_SimpleArray<ON_2dPoint> class wrapper. If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayPoint2d

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayPoint2d : IDisposable

The SimpleArrayPoint2d type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayPoint2d
Initializes a new empty SimpleArrayPoint3d instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of points in this array.
Top
Methods
  NameDescription
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToArray
Copies the unmanaged array to a managed counterpart.
Top
See Also